KBA-01004: What version of SQL Server is required?

Question

What version of SQL Server is required?

Answer

The following SQL versions are supported:

  • SQL Server 2017
  • SQL Server 2016 with SP1
  • SQL Server 2014 with SP2
  • SQL Server 2012 with SP3
  • SQL Server 2008 R2 with SP3 (10.5.4000) for v2016 and v2017 only, with minor limitations on v2017 (Template Matching)
  • SQL Server 2008 with SP4  for v2016 only

Feature Notes

  • SQL Server Reporting Services must be installed.  For high volume sites, do not install SSRS on the same host as SQL or sfPMS!
  • Full Text Indexing must be installed.  This feature is a default for some versions and optional for others.

SQL 2008 R2

You may see “Invalid length parameter passed to the LEFT or SUBSTRING function” creating or routing documents.

Edition Notes

  • Web and Workgroup Editions do not support installing the Reporting Services databases on one server and the web components on another server. Both components of SSRS must be installed on the same server.
  • Some versions of the Runtime Edition that can be purchased with Microsoft Dynamics  does not include SQL Server Reporting Services.
  • Enterprise Edition – most Spitfire Sites will see no immediate benefit from SQL Enterprise Edition.

Additional Comments

SQL Server 2005 SP2 reached end of Microsoft mainstream support in Jan 2012; Spitfire supports SQL 2005 through V4.2.

For full benefit, after upgrading, you should change the Database Properties – Compatibility Level option to the highest version listed above.

Other KBA address migrating SSRS and databases.  See SQL Version chart

 


KBA-01004; Last updated: December 12, 2019 at 17:25 pm;
Keywords:  SQL Server